Extending Dell Customized Bits for VMware vSphere 5.1 to Have Compatibility with VMware View

All the credit for this post goes to blog commenter – Vincent Wu.

VMware recent released a Knowledge Based (KB) article 2035268 that states support for VMware View 5.1.x with vSphere 5.1. It shows two ways to enable support:

1.  You can deploy the updated VMware ESXi 5.1 ISO image. Instructions are in the KB article.

 OR

 2. You can apply Patch ESXi510-201210001 from the Patch Download Center.

If you are using the Dell Customized Bits for VMware vSphere 5.1, then you will need to apply Patch ESXi510-201210001 from the Patch Download Center in order to support View 5.1.x.

Error 0x8007007B While Activating Windows 8 Enterprise

While activating Windows 8 Enterprise downloaded from Microsoft TechNet, I encountered the following error: “Windows can’t activate right now. Error 0x8007007B  The File name, directory name, or volume label syntax is incorrect.

To resolve this error and correctly activate Windows 8 Enterprise, I did the following:

  1. Launch Task Manager.
  2. Click on File -> Run new task.
  3. In the Create new task window,
    1. Type cmd.
    2. Click the Create this task with administrative privileges button.
    3. Click Ok.
  4. From the administrative command prompt, run the following two commands to unistall the product key and then, install the new product key by replacing the XXXXdesignation below.
    1. slmgr -upk
    2. slmgr -ipk XXXX-XXXX-XXXX-XXXX

Slmgr is a Windows script that can be used to change product keys, activate a system, and determine a system’s license type. Slmgr options can be found on technet.microsoft.com.

Now Available: Dell Customized Bits for VMware vSphere 5.1

UPDATE: I am no longer with Dell. Please refer all questions to DellTechCenter.com or @DellTechCenter on Twitter. Thanks.

Dell Customized bits for VMware vSphere 5.1(ESXi 5.1) is now available:

Compatible Dell PowerEdge Servers Include:

PowerEdge 1950

PowerEdge 2900

PowerEdge 2950

PowerEdge 2970

PowerEdge M420

PowerEdge M520

PowerEdge M610

PowerEdge M610x

PowerEdge M620

PowerEdge M710

PowerEdge M710HD

PowerEdge M805

PowerEdge M820

PowerEdge M905

PowerEdge M910

PowerEdge M915

PowerEdge R320

PowerEdge R420

PowerEdge R510

PowerEdge R520

PowerEdge R610

PowerEdge R620

PowerEdge R710

PowerEdge R715

PowerEdge R720

PowerEdge R720xd

PowerEdge R805

PowerEdge R810

PowerEdge R815

PowerEdge R820

PowerEdge R900

PowerEdge R905

PowerEdge R910

PowerEdge T320

PowerEdge T420

PowerEdge T605

PowerEdge T610

PowerEdge T620

PowerEdge T710

Important Release Notes:

You should use VirtualCenter 5.1 (latest build) with this release. The Dell Customized ESXi Factory image does not include Dell OpenManage Server Administrator. For detailed instructions to install and use Dell OpenManage Server Administrator, see the Dell OpenManage documentation at support.dell.com/manuals. Select Software, then Systems Management.

This image is customized by Dell which includes updated Driver/Provider versions. Dell also modifies the below files as part of customization.

– etc/vmware/oem.xml

– etc/vmware/support

The drivers included in this ESXi image by Dell as part of customization are:

Broadcom Network Adapter Drivers & its Versions(Available at vmware.com) ================================================================ tg3 – 3.123b.v50.1

bnx2 – 2.2.1l.v50.1
bnx2x – 1.72.54.v50.2
cnic – 1.72.50.v50.1
bnx2fc – 1.72.51.v50.1
bnx2i – 2.72.10.v50.2
misc-cnic-register – 1.72.1.v50.1
Storage Controller Driver & its Version(Available at vmware.com) =====================================================
mpt2sas – 14.00.00.00.1vmw
Brocade CNA Drivers & its Versions(Available at vmware.com) ====================================================
bfa – 3.1.0.0 bfa – 3.1.0.0
Intel Network Adapter Drivers & its Versions(Available at vmware.com) ===========================================================
igb – 3.4.7.3
Qlogic HBA Drivers & its versions(Available at vmware.com) ==================================================
qla2xxx – 911.k1.1-26vmw
qla4xxx – 624.01.43-1vmw
ima-qla4xxx – 500.2.01.31-1vmw
qlcnic – 5.0.746
qlge – 2.0.0.54
Emulex HBA Drivers & its versions (Available at vmware.com) ===================================================
be2iscsi – 4.1.334.3
ima-be2iscsi – 4.1.334.3
NOTE: The list of files appended/modified/customized by Dell may change during a later release.